Usersnap personal lists are not available
Incident Report for Usersnap
Resolved
Our Usersnap personal lists are back and again fully operational.
Posted 8 months ago. Nov 11, 2016 - 08:07 CET
Identified
We have a issue with showing the dashboard personal lists. No data is lost and the widget is full working.
Posted 8 months ago. Nov 11, 2016 - 07:57 CET