Service Interruptions
Incident Report for Usersnap
Resolved
This incident has been resolved.
Posted Mar 02, 2022 - 17:27 CET
Monitoring
Failing requests were recorded from 12:53 to 13:10 (UTC) when the issue was identified and resolved.
Posted Mar 02, 2022 - 14:21 CET